icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

ros多ADSL负载--掉线后自动修改pcc/nth参数 保证网络畅通[修正版]

发表于 2014年07月29日 软路由版

导读:转自ros软路由论坛。

很多朋友提出了这个问题,假如有4条ADSL跑PCC负载,掉了其中一条后网络就会出现问题,网页打不开或者很慢等等,这是由于PCC参数不匹配造成的。 针对这样的情况WGHBOY兄已经发过一脚本,今天应一个朋友的需要测试后发现该脚本判断不太准确,呵呵。遂花了点时间重新编写达到所要目的。

以4线为例,其中某条线路断了后,会自动判断剩余可用的线路数量然后修改PCC规则的参数,线路恢复正常后会自动把参数修改回正常状态,注意连接标记名称一定要以纯数字“1、2、3、4...”来命名。一般该脚本设置30秒间隔就比较合适。

ros多ADSL负载--掉线后自动修改pcc/nth参数 保证网络畅通[修正版] 软路由 第1张


ros多ADSL负载--掉线后自动修改pcc/nth参数 保证网络畅通[修正版] 软路由 第2张


====================================================

PCC:

{
:local status
:local i "5"
:local x "0"
:local y "0"
:local z "0"
:set x [:len [/interface pppoe-client find running=yes]]
:if ($x<$i) do={
:for ii from=1 to=$i do={
:set status [/interface get [find name=("pppoe-out".$ii)] running]
:if ($status=true) do={
/ip fir man set [find new-connection-mark=$ii] per-connection-classifier=("both-addresses:".$x."/".$y) disable=no;:set y ($y+1)} else={
/ip fir man set [find new-connection-mark=$ii] disable=yes}}}
:if ($x=$i) do={
:set z [:len [/ip fir man find action="mark-connection" disabled=yes chain=prerouting]]
:if ($z>0) do={
:for ii from=1 to=$i do={
/ip fi man set [find new-connection-mark=$ii] per-connection-classifier=("both-addresses:".$x."/".$y) disable=no;:set y ($y+1)}}}}



NTH:

{
:local status
:local i "5"
:local x "0"
:local y "1"
:local z "0"
:set x [:len [/interface pppoe-client find running=yes]]
:if ($x<$i) do={
:for ii from=1 to=$i do={
:set status [/interface get [find name=("pppoe-out".$ii)] running]
:if ($status=true) do={
/ip fir man set [find new-connection-mark=$ii] nth=($x.",".$y) disable=no;:set y ($y+1)} else={
/ip fir man set [find new-connection-mark=$ii] disable=yes}}}
:if ($x=$i) do={
:set z [:len [/ip fir man find action="mark-connection" disabled=yes chain=prerouting]]
:if ($z>0) do={
:for ii from=1 to=$i do={
/ip fi man set [find new-connection-mark=$ii] nth=($x.",".$y) disable=no;:set y ($y+1)}}}}

本文标题:ros多ADSL负载--掉线后自动修改pcc/nth参数 保证网络畅通[修正版]
本文链接:http://www.mulanwei.com.cn/index.php/post/327.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
-2
留言区
留言区

新2彩票靠谱吗 www.040077.com-十分彩官方下载| www.186826.com-分分快三开奖官网| www.476800.com-蚂蚁彩票-| www.595199.com-彩坛的达人七码定位| 七星彩票www.44qxc.com| www.366432.com-八卦预测彩票方法| www.561057.com-355彩票软件下载| www.651015.com-创意水彩画作品| www.hz68.cc-安徽快三口诀| www.m30.mobi-大发快三程序框架| www.877106.com-福星彩开奖结果| www.159059.com-体彩大乐透手机机选| www.266111.com-安微快三万能走势| www.355905.com-福彩分分彩-| 新盈彩www.xinyc5.com| www.79158.com-采开头的四字成语彩| www.38326.cc-网上购彩是什么意思| www.180419.com-兰州快三开奖结果| www.648608.com-香港快三下载| www.928234.com-高频彩种类-| www.yw61.com-3d彩票技巧大全| www.4131.vip-彩虹7无人机首飞| www.90506.com-彩44app-| www.137858.com-中国福彩快三和值| www.344687.com-彩38是那里的平台| www.562876.com-中福快三吧-| www.703090.com-火箭彩票下载app| www.901237.com-福彩独胆杀号3d| www.xf06.com-河北快三开结果| www.71ue.com-恒彩彩票平台代理| www.41942.com-跑马彩票是正规的吗| www.047368.com-大星彩票走势大全| www.385604.com-彩票停售原因| www.175060.com-信誉彩票下载| www.407654.com-霸王港彩网址| www.813401.com-福彩3d的奖金| www.973861.com-中国体彩七星彩玩法| www.294228.com-福彩快三最大遗漏| www.088034.com-彩票站如何在澳客| www.181476.com-湖北快三今天走势| www.254565.com-好彩60123平台| www.320411.com-大乐透购彩截止时间| www.397102.com-v8彩票怎么样| www.7103.cn-七彩油滴建盏| www.336539.com-福彩字谜三字觉论坛| www.86sd.com-众乐彩票线路导航| www.17356.cc-获取彩金是违法吗| www.431117.com-三月份开奖号富彩| www.916129.com-买私彩报警有用吗| www.975145.com-体彩大乐透中前四位| www.cp3327.com-一分快三正规吗| www.ql79.com-江苏快三赢钱的技巧| www.803736.com-体彩排列三数字累加| www.10373.com-唯彩荐球-| www.7282.vip-彩虹之歌儿歌中文| www.380833.com-我要看七乐彩开奖| www.530867.com-水溶性彩铅-| www.529665.com-3彩吧论坛天齐网| www.622971.com-快三对子号多少组合| www.46537.com-西蔵快三开奖| www.87bf.com-时时彩代-| www.42rx.com-苹果原彩显示作用| www.458199.com-梦见买的彩票没中奖| www.576694.com-福彩平台有哪些| www.814500.com-听吉林快三-| 购彩票www.c5237.com| www.59838.com-爱彩彩票平台| www.030966.com-銘發彩票骗局| www.117828.com-分分彩票技巧| www.968689.com-香港买的彩金值钱吗| www.61hf.com-精彩网页设计| www.3545.vip-福彩项目-| www.604898.com-乐发彩票平台| www.84of.com-北控京彩-| www.lj60.com-彩网导航-| www.611116.cc-彩35的网址-| www.700799.com-彩票通怎么下载| www.49985.com-6十1七乐彩-| www.774759.com-彩78彩票网-| www.45sc.com-彩票实体店几点开门| www.1108.org-湖北省福彩快三开奖| www.9959.pw-体彩利润多少个点| www.50018.com-华宇装潢彩票能玩吗| www.163497.com-中国福彩快三是什么| www.66330.cc-2118彩票网下载| www.103964.com-手手机彩票网| www.166736.com-福建快三预测| www.fk5.com-福利彩票输入查询| www.223081.com-贵州体育彩票中奖| www.bw65.com-江苏快三豹子推荐号| www.am70.cc-收贵州快三-| www.xt03.com-好想中彩票买部车| www.78427.com-双彩网官网-| www.28ik.com-星耀国际彩票有人带| www.874133.com-福彩第二版-| www.cai186.com-江西快三开奖号查询| www.730929.com-中福彩票可以玩吗| www.831101.com-广州彩妆厂家| www.913150.com-彩客网能提现吗| www.983724.com-快三车站-| www.av86.cc-体彩速查表-| www.ws53.com-快三20分钟-| www.ks81.com-五分快三网站| www.75ox.com-古建彩绘纹样草图| www.263585.com-彩吧图库二版| www.981831.com-快三和值速查表| www.00oy.com-赞美彩虹的诗句李白| www.96156.com-什么是责任体彩| www.753297.com-中华彩吧合法吗| www.856453.com-苏州体彩店转让| www.157331.com-91竞彩之家改名| www.237916.com-手机彩票33登录| www.8214.vip-投彩赚彩金-| www.638590.com-竞彩店址查询| www.639453.com-体彩机转让信息| www.720448.com-七星彩最新开奖号| www.829227.com-怎么下载彩聊| www.537325.com-春秋彩票害人不浅| www.778034.com-978彩票邀请码| www.525273.com-福彩3d中彩票| www.uf.com-河北快三开走势图| www.890407.com-全民彩票安装| www.960756.com-大众彩票计划群| 8号彩票www.60108w.com| www.871100.com-彩票投注计算软件| www.933469.com-全国高频彩票app| www.980218.com-彩77官网苹果版| www.cp314.com-快三开奖结果广西| www.632552.com-彩票什么规则| www.472444.com-彩票软件吧-| www.76629.cc-广西新快三-| www.04tc.com-彩色铅笔画的工具| www.80oq.com-骗局让你投彩票| www.918282.com-幸运飞艇是福彩吗| www.998574.com-快三杀胆-| www.564.me-天天分分彩开奖| www.yn75.com-江苏快三中奖率高吗| www.93873.cc-绿好彩价格-| www.87966.com-佳缘带人玩彩票| www.568640.com-梦见彩票中奖后真中| www.24ht.com-尼彩iphone7| www.47433.com-118彩票官方网站| www.23428.cc-人工彩票计划网| www.64086.com-竞彩返还率变化| www.349988.com-绝望时买彩票都不中| www.685430.com-双彩球39-| www.803712.com-香港二分彩-| www.888858.com-彩票网站是骗局吗| www.947792.com-福彩什么-| www.990989.com-彩票首页121网站| www.cp6679.com-搜索湖北快三预测| www.975027.com-七星彩长条最新图片| 99彩票www.655802.com| www.ex01.com-犀牛彩票-| www.vp83.com-湖北福彩网彩票| www.332912.com-福彩排列3预测| www.654537.com-帝一娱乐官网时时彩| www.333779.com-体育彩票怎么代理| www.4750.vip-英国男子彩票| www.881671.com-c58彩票下载安装| www.966775.com-大连体彩11选5| www.co31.com-福彩时时彩怎么玩| www.z43.net-金彩网正规吗| www.988444.com-广东福彩领奖流程|